summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkikislater2021-06-19 12:15:05 +0400
committerkikislater2021-06-19 12:15:05 +0400
commit94d6004436bee4ba53e136387cea1f362a4d1068 (patch)
tree3d30f2817583c30b15057ef115008ca3ed620796 /PKGBUILD
parent4e3f393b109846a8d9efc76ca69c387822ca05f0 (diff)
downloadaur-94d6004436bee4ba53e136387cea1f362a4d1068.tar.gz
Compatibility with gdal 3.3.0 and locale ..
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fb5f080e312..daa9632a0f2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Doug Newgard <scimmia at archlinux dot org>
+# Maintainer: Sylvain POULAIN <sylvain dot poulain at giscan dot com>
+# Contributor: Doug Newgard <scimmia at archlinux dot org>
# Contributor: Maciej Sieczka <msieczka at sieczka dot org>
pkgname=grass
pkgver=7.8.5
-pkgrel=1
+pkgrel=2
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
arch=('i686' 'x86_64')
@@ -15,9 +16,15 @@ depends=('bzip2' 'cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos
makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
-source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz")
-md5sums=('91f4830a5164cea703384814cd89cdf9')
+source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz"
+ "https://github.com/OSGeo/grass/commit/b86314c7.patch")
+md5sums=('91f4830a5164cea703384814cd89cdf9'
+ 'e72affb054af2794560971ddab90d0a2')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/b86314c7.patch"
+}
build() {
cd $pkgname-$pkgver
@@ -37,6 +44,7 @@ build() {
--with-bzlib \
--with-zstd
+ LC_ALL=C
make
}