summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2017-07-01 00:06:11 -0500
committerDoug Newgard2017-07-01 00:06:11 -0500
commita06b3065ffd96d6bf73d24706e9d898dee5ca61d (patch)
tree9512daa0a00e03ba68e48dae7ab20d297b6abe2d /PKGBUILD
parent5dc428ae487be5e21d44df831588e6dd7f5971f6 (diff)
downloadaur-a06b3065ffd96d6bf73d24706e9d898dee5ca61d.tar.gz
Corrected GCC7 fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40034ab7e9f2..5bc36a00e9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,15 +16,15 @@ makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz"
- "https://trac.osgeo.org/grass/raw-attachment/ticket/3331/ctypesgencore_preprocessor_fix.diff")
+ "changeset_71219.diff::https://trac.osgeo.org/grass/changeset/71219?format=diff&new=71219")
md5sums=('5c858c718d40a4f3e82741e60c9f7b97'
- '2b70a7ddece3563dc5cf4b95b5b45665')
+ '107f39c90d40f566edff5095cc1264a1')
prepare() {
cd $pkgname-$pkgver
# GCC7 patch
- patch -Np0 -i ../ctypesgencore_preprocessor_fix.diff
+ patch -Np4 -i ../changeset_71219.diff
# Change everything to use python2
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")