summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManolo Martínez2015-10-06 11:06:54 +0200
committerManolo Martínez2015-10-06 11:06:54 +0200
commit6f0dd7428f851a1ffaf4450cee70b6d1a0a504fb (patch)
tree75582a8662c3810f6dd919b2f3c52f53d2f24378 /PKGBUILD
downloadaur-6f0dd7428f851a1ffaf4450cee70b6d1a0a504fb.tar.gz
First import to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ff034ab897c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Manolo Martínez <manolo@austrohungaro.com>
+
+_pkgname=greg
+pkgname=greg-git
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="A command-line podcast aggregator."
+arch=(any)
+url="https://github.com/manolomartinez/greg"
+license=('GPL')
+depends=('python-feedparser')
+optdepends=('python3-stagger-svn: writing metadata'
+ 'wget: alternative downloadhandler'
+ 'aria2: alternative downloadhandler'
+ 'python-beautifulsoup4: convert html to text for tagging')
+makedepends=('git')
+provides=('greg')
+conflicts=('greg')
+source=('git://github.com/manolomartinez/greg.git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ msg "Running setup.py..."
+ python setup.py install --root="${pkgdir}" --optimize=1
+}