summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNing Sun2022-12-08 14:06:13 +0800
committerNing Sun2022-12-08 06:06:11 +0000
commit6c62abbd13e01f60bd1eb3b4b9095897dd427230 (patch)
tree9adecfd7aed6d5d62179ea9f04f283e5547b6cf5 /PKGBUILD
parent22faeb907f30bd843dfa1cd971a0b04bf8cee7cf (diff)
downloadaur-6c62abbd13e01f60bd1eb3b4b9095897dd427230.tar.gz
feat: add systemd service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 642977defe0c..fcc9ca188fac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=greptimedb-bin
pkgver=0.1.0.20221205
_pkgvergh=v0.1.0-alpha-20221205-weekly
-pkgrel=1
+pkgrel=3
pkgdesc='Open-source time-series database.'
arch=('x86_64')
url='https://github.com/GreptimeTeam/greptimedb'
@@ -11,9 +11,15 @@ license=('Apache-2.0')
provides=('greptimedb')
conflicts=()
-source=("greptime-linux-amd64-${pkgver}.tgz::https://github.com/GreptimeTeam/greptimedb/releases/download/${_pkgvergh}/greptime-linux-amd64.tgz")
-sha256sums=("fed5fddadb2d580cbf68d4a2dcfa4e7f2686f04bf4a557c7525e3125fbeb66fb")
+source=("greptime-linux-amd64-${pkgver}.tgz::https://github.com/GreptimeTeam/greptimedb/releases/download/${_pkgvergh}/greptime-linux-amd64.tgz"
+ "greptimedb.sysusers"
+ "greptimedb.service")
+sha256sums=("fed5fddadb2d580cbf68d4a2dcfa4e7f2686f04bf4a557c7525e3125fbeb66fb"
+ "SKIP"
+ "SKIP")
package() {
install -Dm755 "${srcdir}/greptime" "${pkgdir}/usr/bin/greptime"
+ install -Dm644 "${srcdir}/greptimedb.service" "${pkgdir}/usr/lib/systemd/system/greptimedb.service"
+ install -Dm644 "${srcdir}/greptimedb.sysusers" "${pkgdir}/usr/lib/sysusers.d/greptimedb.conf"
}