summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSmooz2018-11-13 15:21:15 +0100
committerSmooz2018-11-13 15:21:15 +0100
commit7b5862d1a1d3d1d265d8554ebed1a65f6aafb60e (patch)
treea691a34375e4a941a4f7d6a5edf484b4171a8bc4 /PKGBUILD
downloadaur-7b5862d1a1d3d1d265d8554ebed1a65f6aafb60e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc5e182ebafd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: smooz <https://github.com/smo0z>
+# Contributor: dunon <https://gitlab.gnome.org/dunon>
+
+pkgname=grevis-git
+pkgver=r25.8444fec
+pkgrel=1
+pkgdesc='A simple game launcher'
+arch=('any')
+url='https://gitlab.gnome.org/dunon/grevis'
+license=('GPL3')
+depends=('python3' 'gtk3>=3.14')
+makedepends=('meson>=0.40' 'ninja' 'git')
+source=('grevis::git+https://gitlab.gnome.org/dunon/grevis.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ meson builddir --prefix="/usr"
+ DESTDIR="$pkgdir" ninja -C builddir install
+} \ No newline at end of file