summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-02-12 00:03:11 +0000
committerBioArchLinuxBot2023-02-12 00:03:11 +0000
commit227e47d6f48f41287c66a56e7a17fcc397e7e553 (patch)
tree7e9c12046d13b7983c463e7de421543209402f69 /PKGBUILD
parent5bf4205e779e695e0986987d63bd2d853277d7ea (diff)
downloadaur-227e47d6f48f41287c66a56e7a17fcc397e7e553.tar.gz
[lilac] updated to 20200626.145814-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82c1602b2ba5..e702841f2845 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,32 +4,32 @@
# Contributor: big_gie nbigaouette . at . gmail.com
pkgname=gri
-pkgver=2.12.23
-pkgrel=10
+pkgver=20200626.145814
+pkgrel=1
pkgdesc="A script-based language for scientific graphics programming"
arch=('i686' 'x86_64')
license=('GPL')
url="http://gri.sourceforge.net/"
-depends=('perl')
-makedepends=('ghostscript' 'imagemagick' 'texlive-core' 'perl-perl4-corelibs')
-source=("https://github.com/dankelley/gri/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('7199abb7be98a0de7cade63122112c57edeab6eea289b4c567ad171ba0a620ae')
+depends=('perl' 'netcdf')
+makedepends=('ghostscript' 'netcdf' 'imagemagick' 'texlive-core' 'perl-perl4-corelibs' 'git')
+source=('gri::git+https://github.com/dankelley/gri.git#commit=d9969d1')
+md5sums=('SKIP')
options=('!makeflags')
prepare() {
- cd $pkgname-$pkgver
+ cd $pkgname
aclocal
autoconf
automake --add-missing
}
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
CXXFLAGS+=" -fpermissive" ./configure --prefix=/usr
make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
make DESTDIR=$pkgdir install
}