summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordllud2022-06-02 20:19:08 +0100
committerdllud2022-06-02 20:19:08 +0100
commit25180708900c74174e6d2a5ba515e573b4960326 (patch)
treedc364a147c8f11040ec0c071869c78320e541c5d /PKGBUILD
parenta70e9725b12a8000ec98b20662ad54cf13110253 (diff)
downloadaur-grin-wallet.tar.gz
Update to v5.1.0
Now fetching sources via tarball instead of git. Much faster and one less build dependency needed (git).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 795cb9e50e15..48b9767287d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: dllud <dllud riseup net>
pkgname=grin-wallet
-pkgver=5.0.3
+pkgver=5.1.0
pkgrel=1
pkgdesc="Reference implementation of Grin's wallet."
arch=('i686' 'x86_64')
url='https://github.com/mimblewimble/grin-wallet'
license=('Apache')
optdepends=('tor: for immediate transactions through Tor anonymizing network')
-makedepends=('clang' 'git' 'rust')
-source=("$pkgname::git+https://github.com/mimblewimble/grin-wallet.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+makedepends=('clang' 'rust')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mimblewimble/grin-wallet/archive/v$pkgver.tar.gz")
+b2sums=('b681b173b76d4d4ffbe72321ad568b533fffdcb43f590ac72b1e103c695826b6a09fe237018c5cca0ea3054cd453232c14bf784f104c18be6a878ec7b933d561')
build() {
- cd ${pkgname}
+ cd "${pkgname}-${pkgver}"
cargo build --release
}
package() {
- cd ${pkgname}
+ cd "${pkgname}-${pkgver}"
install -Dm755 -t "${pkgdir}/usr/bin" target/release/grin-wallet
}