summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2021-03-17 00:07:35 +0100
committerGordian Edenhofer2021-03-17 00:08:07 +0100
commit380f057502eaf189a9574b38a3af2ea43d28f0da (patch)
treec47e23c2583dac4ca8824234a882adb0792b997d /PKGBUILD
parente8311ef74e2acf12bb867924f3d7af2a07f69663 (diff)
downloadaur-380f057502eaf189a9574b38a3af2ea43d28f0da.tar.gz
upgpkg: grive 0.5.1-3
Backport fix for compilation error.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c79428aceb67..5f4408858b9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=grive
pkgver=0.5.1
-pkgrel=2
+pkgrel=3
pkgdesc="An open source Linux client for Google Drive with support for the new Drive REST API and partial sync"
arch=('i686' 'x86_64')
url='https://github.com/vitalif/grive2'
@@ -15,8 +15,16 @@ optdepends=("inotify-tools: scheduled syncs and syncs on file change events"
"cppunit: unit tests"
"binutils: backtrace and libiberty")
makedepends=('cmake' 'boost')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/vitalif/grive2/archive/v${pkgver}.tar.gz")
-sha512sums=('609837fc93ad78d143dcb4d1f558743d413c887fec2e9aaac81edd58549b812db859aab5ce7f664f06564779cff4bae32d43529e47fcc36640f1a9b52c5b5888')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/vitalif/grive2/archive/v${pkgver}.tar.gz"
+ "binutils_compilation.patch"::"https://github.com/vitalif/grive2/commit/b4d6ac055f8f16ac735a70036243bc4ea2334039.patch")
+sha512sums=('609837fc93ad78d143dcb4d1f558743d413c887fec2e9aaac81edd58549b812db859aab5ce7f664f06564779cff4bae32d43529e47fcc36640f1a9b52c5b5888'
+ 'b425c524b28a3e245a4de6090b052a2b1e08a06b5b8227450f91a127d4ea67cc8b1f3a74ac802f1525126d236fa1ad2de0a171ef0fa241ad27b1164606ec0501')
+
+prepare() {
+ cd "${srcdir}/${pkgname}2-${pkgver}"
+
+ patch -Np1 -i ../binutils_compilation.patch
+}
build() {
cd "${srcdir}/${pkgname}2-${pkgver}"