summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2022-06-03 22:24:00 +0200
committerGordian Edenhofer2022-06-03 22:24:00 +0200
commitdb6ec56e54e15fa29d4b623698aded8b5809dc1d (patch)
tree5abc4d01a8a3b882f8dc2df52d4d98337408c60b /PKGBUILD
parent380f057502eaf189a9574b38a3af2ea43d28f0da (diff)
downloadaur-db6ec56e54e15fa29d4b623698aded8b5809dc1d.tar.gz
upgpkg: grive 0.5.1-4
Fix compilation by patching sources. Furthermore, update a checksum.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f4408858b9c..8c94c0cd0b45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=grive
pkgver=0.5.1
-pkgrel=3
+pkgrel=4
pkgdesc="An open source Linux client for Google Drive with support for the new Drive REST API and partial sync"
arch=('i686' 'x86_64')
url='https://github.com/vitalif/grive2'
@@ -16,14 +16,18 @@ optdepends=("inotify-tools: scheduled syncs and syncs on file change events"
"binutils: backtrace and libiberty")
makedepends=('cmake' 'boost')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/vitalif/grive2/archive/v${pkgver}.tar.gz"
- "binutils_compilation.patch"::"https://github.com/vitalif/grive2/commit/b4d6ac055f8f16ac735a70036243bc4ea2334039.patch")
+ "binutils_compilation.patch"::"https://github.com/vitalif/grive2/commit/b4d6ac055f8f16ac735a70036243bc4ea2334039.patch"
+ "syncer_compilation.patch"::"https://patch-diff.githubusercontent.com/raw/vitalif/grive2/pull/363.patch"
+ )
sha512sums=('609837fc93ad78d143dcb4d1f558743d413c887fec2e9aaac81edd58549b812db859aab5ce7f664f06564779cff4bae32d43529e47fcc36640f1a9b52c5b5888'
- 'b425c524b28a3e245a4de6090b052a2b1e08a06b5b8227450f91a127d4ea67cc8b1f3a74ac802f1525126d236fa1ad2de0a171ef0fa241ad27b1164606ec0501')
+ '61b4b642c3f290bf3c4dcc9c1eeccc3aab4cd0802fba0971dc2475152967856b16ee8194038d93be8060318c8ee0b242705ceae3412cc1053ad39a95ce0e9795'
+ '9c4d73105309bb25e03d692313c46c5281b8b0b1f1f3f4fb7bfdd5d167d642e966203024d675d9139ca92de72a2d796819f04e8940da9c8bbb746eb8b5ed615f')
prepare() {
cd "${srcdir}/${pkgname}2-${pkgver}"
patch -Np1 -i ../binutils_compilation.patch
+ patch -Np1 -i ../syncer_compilation.patch
}
build() {