summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-04-02 11:41:49 +0200
committerHector Martinez-Seara2019-04-02 11:41:49 +0200
commit0457509df28d021a99eb1e126e1b779bd8050eab (patch)
treedca1b281522c89e7800085b74110a5ea306383f4 /PKGBUILD
parent3f4ead81058276ad84cf7efaa1281340223b3dec (diff)
downloadaur-0457509df28d021a99eb1e126e1b779bd8050eab.tar.gz
CUDA now supports default system gcc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 1 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1a7b3a5a68f..c07fbc0e03f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gromacs
pkgver=2019.1
-pkgrel=1
+pkgrel=2
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
@@ -19,13 +19,6 @@ options=('!libtool')
source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
sha1sums=('f9abf82ecbe67b8dfe66874b828c4da2bb780376')
-#With gcc7 currently there are less errors in the tests
-# also the compilation is possible in cuda capable machines
-export CC=gcc-7
-export CXX=g++-7
-export CFLAGS="-march=native -O2 -pipe -fstack-protector-strong -fno-plt"
-export CXXFLAGS="${CFLAGS}"
-
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
#trajectory file format that can be read by
@@ -43,9 +36,6 @@ build() {
-DGMX_DOUBLE=ON \
-DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON
-# -DGMX_LIBS_SUFFIX=_d
-# -DBUILD_SHARED_LIBS=ON \
-# -DGMX_X11=ON \
make
msg2 "Building the single precision files"
@@ -55,8 +45,6 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib\
-DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON
-# -DBUILD_SHARED_LIBS=ON \
-# -DGMX_X11=ON \
make
}