summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHector Martinez-Seara2020-10-14 21:35:29 +0200
committerHector Martinez-Seara2020-10-14 21:35:29 +0200
commitf403d6854234e7b98dcf788f6e272342758066f0 (patch)
tree6408b3b1a08bce88964d3c14fe17017ea5f068a1 /PKGBUILD
parent21684c7d6cb01b0f4f5f4182223cdf16c9e3a645 (diff)
downloadaur-f403d6854234e7b98dcf788f6e272342758066f0.tar.gz
Update gromacs 2020.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40e46f27694c..e4c500393ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Hector <hsearaDOTatDOTgmailDOTcom>
pkgname=gromacs
-pkgver=2020.3
+pkgver=2020.4
pkgrel=1
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
@@ -14,10 +14,10 @@ optdepends=('cuda: Nvidia GPU support'
'perl: needed for demux.pl and xplor2gmx.pl'
'opencl-mesa: OpenCL support for AMD GPU'
'opencl-nvidia: OpenCL support for Nvidia GPU')
-makedepends=('cmake' 'libxml2' 'hwloc' 'gcc8')
+makedepends=('cmake' 'libxml2' 'hwloc' 'gcc9')
options=('!libtool')
source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
-sha256sums=('903183691132db14e55b011305db4b6f4901cc4912d2c56c131edfef18cc92a9')
+sha256sums=('5519690321b5500c7951aaf53ff624042c3edd1a5f5d6dd1f2d802a3ecdbf4e6')
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
@@ -25,8 +25,8 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#VMD installation (e.g. AMBER's DCD format).
#For cuda8 support gcc8 is required, if you do not need cuda support comment the next two lines
-export CC=gcc-8
-export CXX=g++-8
+export CC=gcc-9
+export CXX=g++-9
build() {
mkdir -p ${srcdir}/{single,double}