summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHiroshi Hatake2019-03-02 18:13:34 +0900
committerHiroshi Hatake2019-03-02 18:13:34 +0900
commit67471de514e6f6849acd5d9a0209b8c4ab6612cf (patch)
treee073078ed9f302b22f101b285f20d5923e0a09bd /PKGBUILD
parentfc7a0b71355f8db49b3287dea7a2e84d911797e4 (diff)
downloadaur-67471de514e6f6849acd5d9a0209b8c4ab6612cf.tar.gz
groonga 9.0.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 321ebe6907bc..5a00e1bb75d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
pkgname=groonga
pkgver=9.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="An opensource fulltext search engine."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="http://groonga.org/"
license=('LGPL2')
source=("http://packages.groonga.org/source/groonga/$pkgname-$pkgver.tar.gz"
"groonga-httpd.service")
-depends=('zlib' 'lz4' 'glib2' 'libedit' 'zeromq' 'libevent' 'mecab' 'mecab-ipadic')
-optdepends=('cutter-test_framework' 'ruby' 'mercurial' 'kytea' 'snowball-c')
+depends=('zlib' 'lz4' 'glib2' 'libedit' 'zeromq'
+ 'libevent' 'mecab' 'mecab-ipadic')
+optdepends=('cutter-test_framework' 'ruby' 'mercurial' 'kytea' 'snowball-c'
+ 'autoconf-archive' 'arrow')
build() {
+ # TODO: Enable arrow later
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr \
--localstatedir=/var \
@@ -22,6 +25,7 @@ build() {
--with-zlib \
--with-lz4 \
--without-stemmer \
+ --disable-arrow \
--enable-shared=yes \
--enable-static=yes \
--with-mecab \