summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornick black2020-11-17 12:22:41 -0500
committernick black2020-11-17 12:22:41 -0500
commit3aaf9aa25e5abb6027ed3565c7312465923c5387 (patch)
treea857b48d545860b81cc2e0ce8fdb79a41229ca36 /PKGBUILD
parent39da22ac4f51a39cb19d1e2fc671f127fcf69d39 (diff)
downloadaur-3aaf9aa25e5abb6027ed3565c7312465923c5387.tar.gz
Install to /usr/bin not /usr/sbin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31d673c237e8..cb361f106b1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=growlight
pkgver=1.2.19
-pkgrel=2
+pkgrel=3
pkgdesc="Disk manipulation and system preparation tool"
url="https://nick-black.com/dankwiki/index.php/Growlight"
license=('GPL3')
arch=('x86_64')
-# ncurses and readline are found without our help. Don't explicitly list them.
+# readline is found without our help. Don't explicitly list it.
# The same goes for device-mapper.
depends=('cryptsetup' 'libatasmart' 'libpciaccess' 'pciutils' 'notcurses>=2.0.1')
makedepends=('cunit' 'cmake' 'pandoc')
@@ -24,7 +24,9 @@ source=("https://github.com/dankamongmen/growlight/archive/v${pkgver}.tar.gz")
prepare() {
mkdir -p "${pkgname}-${pkgver}/build"
- cd "${pkgname}-${pkgver}/build"
+ cd "${pkgname}-${pkgver}"
+ sed -i -e 's/sbin/bin/g' CMakeLists.txt
+ cd "build"
if pkg-config --modversion libzfs > /dev/null 2>&1 ; then
cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=RelWithDebInfo
else