summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornick black2020-06-29 20:01:08 -0400
committernick black2020-06-29 20:01:08 -0400
commit4a494080864e871944733aac9a383bd4362cec14 (patch)
treeb8a4e5d4a675e3b0244cba279f5693a44e45e701 /PKGBUILD
parenteb392d0eab918e90fc90f6eb519a0420fd3bd25a (diff)
downloadaur-4a494080864e871944733aac9a383bd4362cec14.tar.gz
new upstream, switch to cmake from autotools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8431f036bdd..48b79774221e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=growlight
-pkgver=1.2.5
+pkgver=1.2.6
pkgrel=1
pkgdesc="Disk manipulation and system preparation tool"
url="https://nick-black.com/dankwiki/index.php/Growlight"
@@ -10,9 +10,8 @@ arch=('x86_64')
# ncurses and readline are found without our help. Don't explicitly list them.
# The same goes for device-mapper.
depends=('cryptsetup' 'libatasmart' 'libpciaccess' 'pciutils' 'notcurses>=1.3.2')
-makedepends=('cunit' 'docbook-xsl' 'autoconf-archive' 'libxslt' 'autoconf')
-optdepends=('jfsutils: JFS manipulation'
- 'xfsprogs: XFS manipulation'
+makedepends=('cunit' 'docbook-xsl' 'cmake' 'libxslt')
+optdepends=('jfsutils: JFS manipulation' 'xfsprogs: XFS manipulation'
'mdadm: Linux MDRAID manipulation'
'btrfs-progs: Btrfs manipulation'
'hfsprogs: HFS (MacOS) manipulation'
@@ -23,26 +22,25 @@ optdepends=('jfsutils: JFS manipulation'
'zfs-utils: ZFS-on-Linux manipulation')
source=("https://github.com/dankamongmen/growlight/archive/v${pkgver}.tar.gz")
-build() {
- cd "$pkgname-$pkgver"
- autoreconf -fis
+prepare() {
+ mkdir -p "${pkgname}-${pkgver}/build"
+ cd "${pkgname}-${pkgver}/build"
if pkg-config --modversion libzfs > /dev/null 2>&1 ; then
- ./configure --prefix=/usr
+ cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=RelWithDebInfo
else
echo "Building without ZFS support..."
- ./configure --prefix=/usr --disable-zfs
+ cmake .. -DUSE_LIBZFS=off -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=RelWithDebInfo
fi
- make
}
-package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+build() {
+ cd "${pkgname}-${pkgver}/build"
+ make
}
-check() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" check
+package() {
+ cd "${pkgname}-${pkgver}/build"
+ make install DESTDIR="$pkgdir"
}
-sha256sums=('61803dbf2c424e42e29913b03364d68e272fa65bf8042a44c87811a5f1503f05')
+sha256sums=('01cd0abbf42376c949ccf3126e5cb9aafcf15aac0a583e1a7c7c4a5fe879ac61')