summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-19 21:18:00 -0400
committertheunpleasantowl2018-08-19 21:18:00 -0400
commitab2a270cc288486d40aca2b1ac7bc908cb5d99ed (patch)
tree7ac7949a06a6dbb6474d30e16942d41e304159b0 /PKGBUILD
parent4e33a526016b4322a2f562765adc8265df836bb6 (diff)
downloadaur-ab2a270cc288486d40aca2b1ac7bc908cb5d99ed.tar.gz
Stage for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 9 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d85de7cd5aa0..dd81a7a9d59c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,26 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
-# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
pkgname=grr.app
_pkgname=Grr
pkgrel=1
pkgver=1.0
-pkgdesc="A Rss reader for GNUstep."
+pkgdesc="An Rss reader for GNUstep and Macintosh"
arch=('i686' 'x86_64')
url="http://www.nongnu.org/gap/grr/index.html"
license=('GPL')
-groups=('gnustep')
-depends=('gnustep-gui'
- 'librsskit')
-makedepends=('gcc-objc'
- 'gnustep-make')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back' 'rsskit')
+makedepends=('gcc-objc' 'gnustep-make')
source=("http://savannah.nongnu.org/download/gap/$_pkgname-$pkgver.tar.gz")
sha256sums=('62537cf73b2604cafe541e7cb5cb7eabb0b5da9e43662737efaa7676336a9994')
build() {
cd "$_pkgname-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
-
package() {
cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-}
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file