summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2018-10-20 01:23:53 +0200
committerMaxim Baz2018-10-20 01:56:35 +0200
commit04413273b7bbd37cb8a461fd6cdda093685f8b5f (patch)
tree3ecff4eb052d2b94ae3d3a35f65a628c37d60256 /PKGBUILD
parent2fb640f10d6688692565e99b5adf27b9428a32c8 (diff)
downloadaur-04413273b7bbd37cb8a461fd6cdda093685f8b5f.tar.gz
grub-btrfs: cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d672f3182f9..d9152157f273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,26 @@
pkgname=grub-btrfs
pkgver=3.4
pkgrel=1
-pkgdesc="Include btrfs snapshots in GRUB boot options"
-arch=("any")
-url="https://github.com/Antynea/grub-btrfs"
-license=("GPL3")
-depends=("btrfs-progs" "grub")
-optdepends=("snapper: Snapper support")
-conflicts=("grub-btrfs-git")
-source=("https://github.com/Antynea/grub-btrfs/archive/v${pkgver}.tar.gz")
+pkgdesc='Include btrfs snapshots in GRUB boot options'
+arch=('any')
+url='https://github.com/Antynea/grub-btrfs'
+license=('GPL3')
+depends=('btrfs-progs' 'grub')
+optdepends=('snapper: Snapper support')
+conflicts=('grub-btrfs-git')
+install='grub-btrfs.install'
+backup=('etc/grub.d/41_snapshots-btrfs_config')
+source=("https://github.com/Antynea/grub-btrfs/archive/v$pkgver.tar.gz")
sha256sums=('42cebf0630e65563ef9d9063fe3e369109c9560e6b8248ac27450471a78fe843')
-install="grub-btrfs.install"
-backup=("etc/grub.d/41_snapshots-btrfs_config")
package() {
- cd $pkgname-$pkgver
- install -Dm 755 "41_snapshots-btrfs" "${pkgdir}/etc/grub.d/41_snapshots-btrfs"
- install -Dm 755 "41_snapshots-btrfs_config" "${pkgdir}/etc/grub.d/41_snapshots-btrfs_config"
- install -Dm 644 "localisation/fr/grub-btrfs-git.mo" "${pkgdir}/usr/share/locale/fr/LC_MESSAGES/grub-btrfs-git.mo"
- install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/grub-btrfs/LICENSE"
- install -Dm 644 "10-update_grub.conf" "${pkgdir}/etc/systemd/system/snapper-timeline.service.d/10-update_grub.conf"
- install -Dm 644 "10-update_grub.conf" "${pkgdir}/etc/systemd/system/snapper-cleanup.service.d/10-update_grub.conf"
+ cd "$pkgname-$pkgver"
+ install -Dm755 -t "$pkgdir/etc/grub.d" 41_snapshots-btrfs
+ install -Dm755 -t "$pkgdir/etc/grub.d" 41_snapshots-btrfs_config
+ install -Dm644 -t "$pkgdir/usr/share/locale/fr/LC_MESSAGES" localisation/fr/grub-btrfs-git.mo
+ install -Dm644 -t "$pkgdir/usr/share/licenses/grub-btrfs" LICENSE
+ install -Dm644 -t "$pkgdir/etc/systemd/system/snapper-timeline.service.d" 10-update_grub.conf
+ install -Dm644 -t "$pkgdir/etc/systemd/system/snapper-cleanup.service.d" 10-update_grub.conf
}
# vim:set ts=4 sw=4 et: