summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Barnett2016-04-24 20:55:35 -0500
committerJames Barnett2016-04-24 20:55:35 -0500
commit2eb81673b1a9ab0dbc3e84ea81ac60061ea59329 (patch)
treea4bf1b4ba77c8f8350bd626fee236724320befec /PKGBUILD
downloadaur-2eb81673b1a9ab0dbc3e84ea81ac60061ea59329.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb9c058c3a1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: James W. Barnett <james at wbarnett dot us>
+
+pkgname=grub-btrfs
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="grub-btrfs, Include btrfs snapshots at boot options. (grub menu)"
+arch=('any')
+url="https://github.com/Antynea/grub-btrfs"
+license=('GPL3')
+depends=('btrfs-progs' 'grub')
+conflicts=('grub-btrfs-git')
+source=('https://github.com/Antynea/grub-btrfs/archive/v'$pkgver'.tar.gz')
+md5sums=('c4a0e859077581b6498125bcb572c3a1')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "41_snapshots-btrfs" "${pkgdir}/etc/grub.d/41_snapshots-btrfs"
+ install -Dm 644 "localisation/fr/grub-btrfs-git.mo" "${pkgdir}/usr/share/locale/fr/LC_MESSAGES/grub-btrfs-git.mo"
+ install -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}