summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvenomega2020-04-03 14:27:23 -0400
committervenomega2020-04-03 14:27:23 -0400
commit189033f5fa5dac2b54b9afac485c70aa3e4ebad7 (patch)
treeb25bbad92757934189da9663043df1ccbd10b393 /PKGBUILD
parentca8392d94d0ec1b17b7c4d4ccc48622aee84f749 (diff)
downloadaur-189033f5fa5dac2b54b9afac485c70aa3e4ebad7.tar.gz
Updated to grub 2.04, Reworked patches, Deleted unifont nonsense
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD81
1 files changed, 29 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d4255e3ae1c..80c10c409ac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Derived from official Arch Linux grub package
+# Maintainer : Angel Perez <near1297@nauta.cu>
# Maintainer : Martin Villagra <possum@archlinux.org>
-# Contributor : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
-# Derived from official Arch Lnux grub package
+# Contributor: Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
# Maintainer : Christian Hesse <mail@eworm.de>
# Maintainer : Ronald van Haren <ronald.archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
@@ -12,9 +13,7 @@ _IA32_EFI_IN_ARCH_X64="1"
## "1" to enable EMU build, "0" to disable
_GRUB_EMU_BUILD="0"
-_GRUB_EXTRAS_COMMIT="f2a079441939eee7251bf141986cdd78946e1d20"
-
-_UNIFONT_VER="10.0.06"
+_GRUB_EXTRAS_COMMIT="8a245d5c1800627af4cefa99162a89c7a46d8842"
[[ "${CARCH}" == "x86_64" ]] && _EFI_ARCH="x86_64"
[[ "${CARCH}" == "i686" ]] && _EFI_ARCH="i386"
@@ -24,12 +23,13 @@ _UNIFONT_VER="10.0.06"
pkgname="grub-silent"
pkgdesc="GNU GRand Unified Bootloader (2) [without welcome and kernel messages]"
-pkgver=2.02
+pkgver=2.04
pkgrel=1
url="https://www.gnu.org/software/grub/"
arch=('x86_64' 'i686')
license=('GPL3')
backup=('etc/grub.d/40_custom')
+backup=('etc/default/grub')
install="${pkgname%-*}.install"
options=('!makeflags')
@@ -37,13 +37,13 @@ conflicts=('grub' 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" '
replaces=('grub' 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
provides=('grub' 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
-makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
- 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
-depends=('sh' 'xz' 'gettext' 'device-mapper')
+makedepends=('autogen' 'bdf-unifont' 'git' 'help2man'
+ 'python' 'rsync' 'texinfo' 'ttf-dejavu')
+depends=('device-mapper' 'gettext')
optdepends=('freetype2: For grub-mkfont usage'
'fuse2: For grub-mount usage'
- 'dosfstools: For grub-mkrescue FAT FS and EFI support'
'efibootmgr: For grub-install EFI support'
+ 'dosfstools: For grub-mkrescue FAT FS and EFI support'
'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
'mtools: For grub-mkrescue FAT FS support')
@@ -56,33 +56,25 @@ fi
source=("https://ftp.gnu.org/gnu/${pkgname%-*}/${pkgname%-*}-${pkgver}.tar.xz"
"https://git.savannah.nongnu.org/cgit/grub-extras.git/snapshot/grub-extras-${_GRUB_EXTRAS_COMMIT}.tar.gz"
- "https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"
'01-intel-ucode.patch'
'02-10_linux-detect-archlinux-initramfs.patch'
'03-add-GRUB_COLOR_variables.patch'
- '04-ext4_feature_encrypt.patch'
- '05-gettext_quiet.patch'
- '06-sleep_shift.patch'
- '07-maybe_quiet.patch'
- '08-quick_boot.patch'
- '09-Fix-packed-not-aligned-error-on-GCC-8.patch'
- '10-relocation.patch'
+ '04-gettext_quiet.patch'
+ '05-sleep_shift.patch'
+ '06-maybe_quiet.patch'
+ '07-quick_boot.patch'
'grub.silent')
-sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
- '2844601914cea6b1231eca0104853a93c4d67a5209933a0766f1475953300646'
- '0d81571fc519573057b7641d26a31ead55cc0b02a931589fb346a3a534c3dcc1'
- '37adb95049f6cdcbdbf60ed6b6440c5be99a4cd307a0f96c3c3837b6c2e07f3c'
- 'b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3'
- 'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
- '82b9e3fc8547c496cd28f39e75d8224d83c40481df3bfa33ae8169f7c7861362'
+sha256sums=('e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d'
+ '4fb9b26a597a88d94f2ffbfec53a44041c302fdc452bc6d88575bacf6ef97f70'
+ '53d2f7ce9c704704e354ee2374a782764fcfd0c29a89e5e70923eb8c4681df6f'
+ '43c8efaaa0860286a12a600088b567a70a20eb36005f0cabbe7cf7379e992f3e'
+ 'f77417646a5480623f61006304bf68e3a733e77642978af949d4452f36e3203a'
'39d7843dfe1e10ead912a81be370813b8621794a7967b3cc5e4d4188b5bf7264'
'4b189e00a8c97ec09903e9588e02fc78b4bb114ee4822fcce13811aca00c8884'
'b7489c7facc4fb3dad4426c9c00079b64908640a2bec2409e22194daa3f72af4'
'057f076ddca241d92a094bc05828e3eb18d3439bf4d2f3d8ca8fa1c51b5b1b2b'
- 'e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8'
- '51562fa1016c54567dbf42a86c0cfc902372ab579bbee17879a81aff09b76b99'
- '764844ca8ee0869761cc1a7ed76b5c729ea560664ba26afc339ba4c5d5c7b2e3')
+ '4f2e9d585b7b0ef8ce0d09e88391d1397b50883c7cb1516dc99785934abe15a2')
prepare() {
cd "${srcdir}/grub-${pkgver}/"
@@ -100,10 +92,6 @@ prepare() {
patch -Np1 -i "${srcdir}/03-add-GRUB_COLOR_variables.patch"
echo
- msg "Patch to allow GRUB to mount ext2/3/4 filesystems that have the encryption feature"
- patch -Np1 -i "${srcdir}/04-ext4_feature_encrypt.patch"
- echo
-
msg "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme"
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
@@ -114,30 +102,19 @@ prepare() {
sed 's|GNU/Linux|Linux|' -i "util/grub.d/10_linux.in"
msg "Appling Ubuntu patches for making GRUB silent"
- patch -Np1 -i "${srcdir}/05-gettext_quiet.patch"
- patch -Np1 -i "${srcdir}/06-sleep_shift.patch"
- patch -Np1 -i "${srcdir}/07-maybe_quiet.patch"
- patch -Np1 -i "${srcdir}/08-quick_boot.patch"
- echo
-
- msg "Appling fix for packed not aligned error on GCC-8"
- patch -Np1 -i "${srcdir}/09-Fix-packed-not-aligned-error-on-GCC-8.patch"
- echo
-
- msg "Applying fix for relocation error 0x4"
- patch -Np1 -i "${srcdir}/10-relocation.patch"
+ patch -Np1 -i "${srcdir}/04-gettext_quiet.patch"
+ patch -Np1 -i "${srcdir}/05-sleep_shift.patch"
+ patch -Np1 -i "${srcdir}/06-maybe_quiet.patch"
+ patch -Np1 -i "${srcdir}/07-quick_boot.patch"
echo
msg "Pull in latest language files"
./linguas.sh
echo
- msg "Remove not working langs which need LC_ALL=C.UTF-8"
- sed -e 's#en@cyrillic en@greek##g' -i "po/LINGUAS"
-
- msg "Avoid problem with unifont during compile of grub"
- # http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
- cp "${srcdir}/unifont-${_UNIFONT_VER}.bdf.gz" "unifont.bdf.gz"
+ # Remove lua module from grub-extras as it is incompatible with changes to grub_file_open
+ # http://git.savannah.gnu.org/cgit/grub.git/commit/?id=ca0a4f689a02c2c5a5e385f874aaaa38e151564e
+ rm -rf "$srcdir"/grub-extras/lua
}
_build_grub-common_and_bios() {
@@ -334,8 +311,8 @@ _package_grub-common_and_bios() {
rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.image || true
rm -f "${pkgdir}/usr/lib/grub/i386-pc"/{kernel.exec,gdb_grub,gmodule.pl} || true
-# msg "Install a sample file for /etc/default/grub "
- install -D -m0644 "${srcdir}/grub.silent" "${pkgdir}/etc/default/grub.silent"
+# msg "Install config file for /etc/default/grub "
+ install -D -m0644 "${srcdir}/grub.silent" "${pkgdir}/etc/default/grub"
}
_package_grub-efi() {