summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-06-06 08:58:34 -0600
committeryochananmarqos2019-06-06 08:58:34 -0600
commite5365c075900dda3ec8443dcf4ba8b5f80245fb4 (patch)
treecca9ee7fcd2d6e49873a928e990a22a63f445ad3 /PKGBUILD
downloadaur-e5365c075900dda3ec8443dcf4ba8b5f80245fb4.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cecf60ddfd07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=grub-theme-creator
+pkgver=.0.2
+pkgrel=1
+pkgdesc="Automates the creation of a grub2 theme"
+arch=('any')
+url="https://github.com/petsam/grub-theme-creator"
+license=('GPL3')
+depends=('horizontal-grub' 'imagemagick')
+optdepends=('grub2-theme-preview')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/petsam/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('fb44eba30534736b9af65f07868c104720d92a177c37cc3c1f218f41b454c495')
+
+package() {
+ cd "$pkgname-v$pkgver"
+ install -d $pkgdir/usr/share/prettygrub
+ cp -r templates $pkgdir/usr/share/prettygrub/
+ install -Dm755 prettygrub $pkgdir/usr/bin/prettygrub
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+}