summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErik Dubois2019-02-12 06:53:28 +0100
committerErik Dubois2019-02-12 06:53:28 +0100
commit1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e (patch)
treec208c5f0ffac605b25abd7a9135b2cdc9724bb92 /PKGBUILD
downloadaur-1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e.tar.gz
creation of new package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80c5beed6cf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: erik dubois <erik.dubois@gmail.com>
+
+pkgname=grub-theme-slaze-git
+pkgver=1.1
+pkgrel=1
+pkgdesc='slaze grub2 theme'
+arch=(any)
+url='https://github.com/vinceliuice/grub2-themes'
+license=('GPL')
+depends=('grub')
+optdepends=('grub-customizer')
+makedepends=('git')
+conflicts=()
+install=${pkgname}.install
+source=('git://github.com/vinceliuice/grub2-themes')
+md5sums=('SKIP')
+package() {
+ install -dm755 $pkgdir/boot/grub/themes/
+ cd grub2-themes/grub-theme-slaze
+ cp -r Slaze $pkgdir/boot/grub/themes/
+
+ echo '======='
+ echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m'
+ echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
+ echo '----------'
+ echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
+ echo '======='
+}