summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDct Mei2019-06-19 16:07:35 +0900
committerDct Mei2019-06-19 16:07:35 +0900
commit1ea769e48ed4fd00425385cf74b824bb58744c02 (patch)
tree9002b5a9fe023acba1b3aeb376716ade21d9b5fc /PKGBUILD
parent1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e (diff)
downloadaur-1ea769e48ed4fd00425385cf74b824bb58744c02.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 27 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80c5beed6cf2..222cb8f96b0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: erik dubois <erik.dubois@gmail.com>
+# Maintainer: Dct Mei <dctxmei@gmail.com>
pkgname=grub-theme-slaze-git
-pkgver=1.1
+_pkgname="${pkgname%-*}"
+pkgver=1.0
pkgrel=1
-pkgdesc='slaze grub2 theme'
+pkgdesc="Slaze grub theme"
arch=(any)
-url='https://github.com/vinceliuice/grub2-themes'
-license=('GPL')
-depends=('grub')
-optdepends=('grub-customizer')
-makedepends=('git')
-conflicts=()
-install=${pkgname}.install
-source=('git://github.com/vinceliuice/grub2-themes')
-md5sums=('SKIP')
+url="https://github.com/vinceliuice/grub2-themes"
+license=('GPL3')
+depends=(grub)
+makedepends=(git)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/vinceliuice/grub2-themes.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
package() {
- install -dm755 $pkgdir/boot/grub/themes/
- cd grub2-themes/grub-theme-slaze
- cp -r Slaze $pkgdir/boot/grub/themes/
-
- echo '======='
- echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m'
- echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
- echo '----------'
- echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
- echo '======='
+ name="${pkgdesc%% *}"
+ cd "$srcdir/$_pkgname"
+ install -d "$pkgdir/boot/grub/themes/$name"
+ install -d "$pkgdir/boot/grub/themes/$name/icons"
+ install -Dm 755 common/* "$pkgdir/boot/grub/themes/$name"
+ install -Dm 755 "backgrounds/background-${_pkgname##*-}.jpg" "$pkgdir/boot/grub/themes/$name/background.jpg"
+ install -Dm 755 assets/assets-white/icons/* "$pkgdir/boot/grub/themes/$name/icons"
+ install -Dm 755 assets/assets-white/select/*.png "$pkgdir/boot/grub/themes/$name"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}