summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-07-11 00:21:25 -0700
committerLlewelyn Trahaearn2018-07-11 00:21:25 -0700
commit62595af972b298c21a0b44fa948d8507a9e4ea1f (patch)
tree18f0660c9c9092d390709cefa86fb650eabec9c9 /PKGBUILD
parenta9efb92bdc098974c391c150de0368ab95e965d9 (diff)
downloadaur-62595af972b298c21a0b44fa948d8507a9e4ea1f.tar.gz
Mirror changes in [Core], including FreeType pkg-config fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD138
1 files changed, 38 insertions, 100 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4019c9557af4..7d8a51b36a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _UNIFONT_VER="10.0.06"
[[ "${CARCH}" == "i686" ]] && _EMU_ARCH="i386"
pkgname="grub-git"
-pkgver=2.02.r147.gba474d531
+pkgver=2.02.r152.gec2de93f8
pkgrel=1
pkgdesc="GNU GRand Unified Bootloader (2)"
arch=('x86_64' 'i686')
@@ -53,8 +53,6 @@ source=("grub::git+git://git.savannah.gnu.org/grub.git"
"https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
'10_linux-detect-archlinux-initramfs.patch'
'add-GRUB_COLOR_variables.patch'
- 'freetype-capitalise-variables.patch'
- 'freetype-pkg-config.patch'
'grub.default'
'grub.cfg')
sha256sums=('SKIP'
@@ -63,30 +61,43 @@ sha256sums=('SKIP'
'SKIP'
'b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
- '4153565a0e1428bdacf09a0c646d2106c75182f1753e2a044896d23752295569'
- '3da2764ecc0c2f3cf9a3f94660ed3ebfc1192c6b3df0ee27d78622bf9718228d'
'74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82'
'c5e4f3836130c6885e9273c21f057263eba53f4b7c0e2f111f6e5f2e487a47ad')
validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
'95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+_configure_options=(
+ FREETYPE="pkg-config freetype2"
+ BUILD_FREETYPE="pkg-config freetype2"
+ --enable-mm-debug
+ --enable-nls
+ --enable-device-mapper
+ --enable-cache-stats
+ --enable-grub-mkfont
+ --enable-grub-mount
+ --prefix="/usr"
+ --bindir="/usr/bin"
+ --sbindir="/usr/bin"
+ --mandir="/usr/share/man"
+ --infodir="/usr/share/info"
+ --datarootdir="/usr/share"
+ --sysconfdir="/etc"
+ --program-prefix=""
+ --with-bootdir="/boot"
+ --with-grubdir="grub"
+ --disable-silent-rules
+ --disable-werror
+)
+
prepare() {
cd grub
msg "Patch to detect of Arch Linux initramfs images by grub-mkconfig"
patch -Np1 -i "${srcdir}/10_linux-detect-archlinux-initramfs.patch"
- echo
msg "Patch to enable GRUB_COLOR_* variables in grub-mkconfig"
## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
patch -Np1 -i "${srcdir}/add-GRUB_COLOR_variables.patch"
- echo
-
- msg "Capitalise FreeType vairables to conform to pkg-config macros"
- patch -Np1 -i "${srcdir}/freetype-capitalise-variables.patch"
-
- msg "Use pkg-config to locate FreeType"
- patch -Np1 -i "${srcdir}/freetype-pkg-config.patch"
msg "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme"
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
@@ -99,7 +110,6 @@ prepare() {
msg "Pull in latest language files"
./linguas.sh
- echo
msg "Remove not working langs which need LC_ALL=C.UTF-8"
sed -e 's#en@cyrillic en@greek##g' -i "po/LINGUAS"
@@ -107,6 +117,9 @@ prepare() {
msg "Avoid problem with unifont during compile of grub"
# http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
cp "${srcdir}/unifont-${_UNIFONT_VER}.bdf" "unifont.bdf"
+
+ msg "Run autogen.sh"
+ ./autogen.sh
}
pkgver() {
@@ -141,39 +154,16 @@ _build_grub-common_and_bios() {
unset LDFLAGS
unset MAKEFLAGS
- msg "Run autogen.sh for bios build"
- ./autogen.sh
- echo
-
msg "Run ./configure for bios build"
./configure \
--with-platform="pc" \
--target="i386" \
"${_EFIEMU}" \
- --enable-mm-debug \
- --enable-nls \
- --enable-device-mapper \
- --enable-cache-stats \
--enable-boot-time \
- --enable-grub-mkfont \
- --enable-grub-mount \
- --prefix="/usr" \
- --bindir="/usr/bin" \
- --sbindir="/usr/bin" \
- --mandir="/usr/share/man" \
- --infodir="/usr/share/info" \
- --datarootdir="/usr/share" \
- --sysconfdir="/etc" \
- --program-prefix="" \
- --with-bootdir="/boot" \
- --with-grubdir="grub" \
- --disable-silent-rules \
- --disable-werror
- echo
+ "${_configure_options[@]}"
msg "Run make for bios build"
make
- echo
}
_build_grub-efi() {
@@ -181,12 +171,6 @@ _build_grub-efi() {
cp -r "${srcdir}/grub" "${srcdir}/grub-efi-${_EFI_ARCH}"
cd "${srcdir}/grub-efi-${_EFI_ARCH}"
- if [[ "${_EFI_ARCH}" == "i386" ]]; then
- msg "Fix EFI build for i386"
- sed '/i386 = lib\/i386\/reboot.c;/d' -i "grub-core/Makefile.core.def"
- sed '/i386 = lib\/i386\/reboot_trampoline.S;/d' -i "grub-core/Makefile.core.def"
- fi
-
msg "Unset all compiler FLAGS for ${_EFI_ARCH} efi build"
unset CFLAGS
unset CPPFLAGS
@@ -194,39 +178,25 @@ _build_grub-efi() {
unset LDFLAGS
unset MAKEFLAGS
- msg "Run autogen.sh for ${_EFI_ARCH} efi build"
- ./autogen.sh
- echo
+ if [[ "${_EFI_ARCH}" == "i386" ]]; then
+ msg "Fix duplicate symbol"
+ # http://savannah.gnu.org/bugs/?func=detailitem&item_id=53517
+ sed '/i386 = lib\/i386\/reboot.c;/d' -i "grub-core/Makefile.core.def"
+ sed '/i386 = lib\/i386\/reboot_trampoline.S;/d' -i "grub-core/Makefile.core.def"
+ msg "Run autogen.sh for ${_EFI_ARCH} efi build"
+ ./autogen.sh
+ fi
msg "Run ./configure for ${_EFI_ARCH} efi build"
./configure \
--with-platform="efi" \
--target="${_EFI_ARCH}" \
--disable-efiemu \
- --enable-mm-debug \
- --enable-nls \
- --enable-device-mapper \
- --enable-cache-stats \
--enable-boot-time \
- --enable-grub-mkfont \
- --enable-grub-mount \
- --prefix="/usr" \
- --bindir="/usr/bin" \
- --sbindir="/usr/bin" \
- --mandir="/usr/share/man" \
- --infodir="/usr/share/info" \
- --datarootdir="/usr/share" \
- --sysconfdir="/etc" \
- --program-prefix="" \
- --with-bootdir="/boot" \
- --with-grubdir="grub" \
- --disable-silent-rules \
- --disable-werror
- echo
+ "${_configure_options[@]}"
msg "Run make for ${_EFI_ARCH} efi build"
make
- echo
}
_build_grub-emu() {
@@ -241,61 +211,34 @@ _build_grub-emu() {
unset LDFLAGS
unset MAKEFLAGS
- msg "Run autogen.sh for emu build"
- ./autogen.sh
- echo
-
msg "Run ./configure for emu build"
./configure \
--with-platform="emu" \
--target="${_EMU_ARCH}" \
- --enable-mm-debug \
- --enable-nls \
- --enable-device-mapper \
- --enable-cache-stats \
- --enable-grub-mkfont \
- --enable-grub-mount \
--enable-grub-emu-usb=no \
--enable-grub-emu-sdl=no \
--disable-grub-emu-pci \
- --prefix="/usr" \
- --bindir="/usr/bin" \
- --sbindir="/usr/bin" \
- --mandir="/usr/share/man" \
- --infodir="/usr/share/info" \
- --datarootdir="/usr/share" \
- --sysconfdir="/etc" \
- --program-prefix="" \
- --with-bootdir="/boot" \
- --with-grubdir="grub" \
- --disable-silent-rules \
- --disable-werror
- echo
+ "${_configure_options[@]}"
msg "Run make for emu build"
make
- echo
}
build() {
msg "Build grub bios stuff"
_build_grub-common_and_bios
- echo
msg "Build grub ${_EFI_ARCH} efi stuff"
_build_grub-efi
- echo
if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
msg "Build grub i386 efi stuff"
_EFI_ARCH="i386" _build_grub-efi
- echo
fi
if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
msg "Build grub emu stuff"
_build_grub-emu
- echo
fi
}
@@ -304,7 +247,6 @@ _package_grub-common_and_bios() {
msg "Run make install for bios build"
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo
msg "Remove gdb debugging related files for bios build"
rm -f "${pkgdir}/usr/lib/grub/i386-pc"/*.module || true
@@ -323,7 +265,6 @@ _package_grub-efi() {
msg "Run make install for ${_EFI_ARCH} efi build"
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo
msg "Remove gdb debugging related files for ${_EFI_ARCH} efi build"
rm -f "${pkgdir}/usr/lib/grub/${_EFI_ARCH}-efi"/*.module || true
@@ -336,7 +277,6 @@ _package_grub-emu() {
msg "Run make install for emu build"
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
- echo
msg "Remove gdb debugging related files for emu build"
rm -f "${pkgdir}/usr/lib/grub/${_EMU_ARCH}-emu"/*.module || true
@@ -351,13 +291,11 @@ package() {
if [[ "${CARCH}" == "x86_64" ]] && [[ "${_IA32_EFI_IN_ARCH_X64}" == "1" ]]; then
msg "Package grub i386 efi stuff"
_EFI_ARCH="i386" _package_grub-efi
- echo
fi
if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
msg "Package grub emu stuff"
_package_grub-emu
- echo
fi
msg "Package grub bios stuff"