summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-01-18 16:01:36 +0100
committerAlexander F Rødseth2017-01-18 16:01:36 +0100
commit74584f2bc63a229102c0af6b5f7717dd4fd4d3af (patch)
tree86660c4e626ed65294a11c86b0e261d32b621683 /PKGBUILD
downloadaur-74584f2bc63a229102c0af6b5f7717dd4fd4d3af.tar.gz
Add grumpy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1d61cd12f00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=grumpy
+pkgver=r149.35d1202
+pkgrel=1
+pkgdesc='Grumpy is a Python to Go source code transcompiler and runtime'
+arch=('x86_64' 'i686')
+url='https://github.com/google/grumpy'
+license=('Apache')
+depends=('go' 'python2')
+makedepends=('git' 'go' 'python2')
+options=('!strip')
+source=("git+https://github.com/google/grumpy.git"
+ 'makefile.patch')
+md5sums=('SKIP'
+ '1a73c49f15cd1ab978e5cacd0ea84ecb')
+
+prepare() {
+ cd grumpy
+ patch -p1 -i ../makefile.patch
+}
+
+build() {
+ PYTHON=python2 make -C grumpy -j2
+}
+
+package() {
+ PYTHON=python2 DESTDIR="$pkgdir" make -C grumpy install
+}
+
+# vim:set ts=2 sw=2 et: