summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-01-20 11:17:19 +0100
committerAlexander F Rødseth2017-01-20 11:17:19 +0100
commitc1d6e3d8c6048f6724765346bef4f7d1f2e55c7f (patch)
treee6ebbbe61fc5b72de41bad88b6573cd131c77b91 /PKGBUILD
parent912a52e0bc45989fb5202df834cdecf9bf155919 (diff)
downloadaur-c1d6e3d8c6048f6724765346bef4f7d1f2e55c7f.tar.gz
Using the new make install section
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce2f15d2ebe1..769b75572723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=grumpy
-pkgver=r149.35d1202
+pkgver=0.aa58aa68
pkgrel=1
pkgdesc='Grumpy is a Python to Go source code transcompiler and runtime'
arch=('x86_64' 'i686')
@@ -10,22 +10,15 @@ depends=('go' 'python2')
makedepends=('go' 'python2' 'git')
license=('Apache')
options=('!strip')
-source=("git+https://github.com/google/grumpy.git#commit=35d1202"
- 'makefile.patch')
-md5sums=('SKIP'
- '1a73c49f15cd1ab978e5cacd0ea84ecb')
-
-prepare() {
- cd grumpy
- patch -p1 -i ../makefile.patch
-}
+source=("git+https://github.com/google/grumpy.git#commit=${pkgver#*.}")
+md5sums=('SKIP')
build() {
- PYTHON=python2 make -C grumpy -j2
+ make -C grumpy -j2
}
package() {
- PYTHON=python2 DESTDIR="$pkgdir" make -C grumpy install
+ DESTDIR="$pkgdir" make -C grumpy install
}
# vim:set ts=2 sw=2 et: