summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-09-16 17:07:30 +0800
committerSainnhepark2020-09-16 17:07:48 +0800
commitef9ed1700cc066fe29e319f128c69c0f16a2b710 (patch)
tree161812f342bde5399613791efcdd3f447c52dca2 /PKGBUILD
downloadaur-ef9ed1700cc066fe29e319f128c69c0f16a2b710.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42b84d4c15db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgbase=gruvbox-material-theme-git
+_pkgbase=gruvbox-material-theme
+pkgname=('gruvbox-material-gtk-theme-git'
+ 'gruvbox-material-icon-theme-git')
+pkgver=r8.99ce99e2d
+pkgrel=1
+arch=(any)
+url='https://github.com/sainnhe/gruvbox-material-gtk'
+makedepends=(git)
+license=(MIT)
+source=("${_pkgbase}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgbase}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_gruvbox-material-gtk-theme-git() {
+ pkgdesc='Gruvbox Material theme for GTK, Gnome, Cinnamon, XFCE, Unity and Plank'
+ depends=(gtk3)
+ optdepends=('gtk-engine-murrine: for gtk2 theme'
+ 'gruvbox-material-icon-theme: gruvbox material icon theme')
+ provides=(gruvbox-material-gtk-theme)
+ conflicts=(gruvbox-material-gtk-theme)
+ replaces=(gruvbox-material-gtk-theme)
+
+ install -d "${pkgdir}/usr/share/themes/Gruvbox-Material-Dark"
+ cd "${srcdir}/${_pkgbase}/themes/Gruvbox-Material-Dark"
+ cp -r ./* "${pkgdir}/usr/share/themes/Gruvbox-Material-Dark/"
+}
+
+package_gruvbox-material-icon-theme-git() {
+ pkgdesc='Gruvbox Material icon theme'
+ depends=('gtk-update-icon-cache')
+ optdepends=('gruvbox-material-gtk-theme: gruvbox material gtk theme')
+ provides=(gruvbox-material-icon-theme)
+ conflicts=(gruvbox-material-icon-theme)
+ replaces=(gruvbox-material-icon-theme)
+
+ install -d "${pkgdir}/usr/share/icons/Gruvbox-Material-Dark"
+ cd "${srcdir}/${_pkgbase}/icons/Gruvbox-Material-Dark"
+ cp -r ./* "${pkgdir}/usr/share/icons/Gruvbox-Material-Dark/"
+}