summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:00:53 +0200
committerMaxime Gauduin2015-06-09 12:00:53 +0200
commit1aa3e7ca3ab93a23bb3b86e6eadc4efdcfe3dadc (patch)
tree886435ea30b595acd23ae37a08671e77cacb8bad /PKGBUILD
downloadaur-1aa3e7ca3ab93a23bb3b86e6eadc4efdcfe3dadc.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e7bb968361f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Josip Ponjavic <josipponjavic@gmail.com>
+
+pkgname=gsignond
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='gSSO glib daemon'
+arch=('i686' 'x86_64')
+url='https://01.org/gsso'
+license=('LGPL2.1')
+depends=('dbus' 'libgsignon-glib' 'sqlite')
+makedepends=('git' 'gobject-introspection' 'gtk-doc')
+backup=('etc/gsignond.conf')
+source=('git+https://gitlab.com/accounts-sso/gsignond.git#commit=deb5f757')
+sha256sums=('SKIP')
+
+prepare() {
+ cd gsignond
+
+ mkdir -p m4
+ gtkdocize
+ aclocal
+ autoheader
+ libtoolize --copy --force
+ autoconf
+ automake --add-missing --copy
+ autoreconf --install --force
+}
+
+build() {
+ cd gsignond
+
+ ./configure \
+ --prefix='/usr' \
+ --sysconfdir='/etc' \
+ --enable-dbus-type='session'
+ make
+}
+
+package() {
+ cd gsignond
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: