summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzlsun2016-02-21 15:35:05 +0800
committerzlsun2016-02-21 15:35:05 +0800
commit00f4791e3b1887b15dfca8a92bf89021225b4482 (patch)
tree2b01f8bb8f8785a93f30fd6775ef1d894fb4bf91 /PKGBUILD
downloadaur-00f4791e3b1887b15dfca8a92bf89021225b4482.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08f722ac4df9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: zlsun <zlsun1995 at gmail dot com>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: DrZaius <lou at fakeoutdoorsman dot com>
+# Contributor: Victor Feight <vrfeight3 at gmail dot com>
+
+pkgname=gsimplecal-lunar
+_pkgname=gsimplecal
+pkgver=2.1
+pkgrel=2
+pkgdesc="Simple and lightweight GTK calendar with lunar calendar patch"
+arch=('i686' 'x86_64')
+url="http://dmedvinsky.github.com/$_pkgname"
+license=('BSD')
+depends=('gtk3' 'lunar-calendar')
+conflicts=('gsimplecal')
+provides=('gsimplecal')
+_lunar_patch="$pkgname-$pkgver.patch"
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/dmedvinsky/$_pkgname/archive/v$pkgver.tar.gz"
+ $_lunar_patch)
+md5sums=('170ac0bdc8663d97dec436e45b195491'
+ 'SKIP')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i "$srcdir/$_lunar_patch"
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/COPYING
+}
+