summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-19 21:25:08 -0400
committertheunpleasantowl2018-08-19 21:25:08 -0400
commit8a3168a795c8195c451abc177f5c27329af3aa74 (patch)
treee28c1c8074c4ea6b1359382e7248977a5cf25db0 /PKGBUILD
downloadaur-8a3168a795c8195c451abc177f5c27329af3aa74.tar.gz
Stage for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efb0abe042cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=GSPdf
+pkgname=gspdf.app
+pkgrel=1
+pkgver=0.5
+pkgdesc=' GSPdf is a PDF, PS and EPS viewer for gnustep'
+arch=('i686' 'x86_64')
+url='http://gap.nongnu.org/gspdf/index.html'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back' 'ghostscript')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/GSPdf-0.5.tar.gz")
+sha256sums=('b85e2184e90a46aa054d1bf6577fb19f0c3bd953f0e4ff1b8656528d0dfcf88b')
+
+build() {
+ cd $_pkgname-$pkgver
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}