summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorent Thiéry2020-10-27 11:27:05 +0100
committerFlorent Thiéry2020-10-27 11:27:05 +0100
commit1cc0dc72f4d66197abe717c5c6caf88d54cd9de3 (patch)
treea53673d2f405af0c3868988c2d87504bf99ad938 /PKGBUILD
parentf569f79b70a4cf0e5d1bc60cd0255f8934be9afa (diff)
downloadaur-1cc0dc72f4d66197abe717c5c6caf88d54cd9de3.tar.gz
update to use meson instead of autotools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1015972dc335..53a4c95b2e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Florent Thiéry fthiery@gmail.com
pkgname=gst-instruments-git
pkgver=0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Set of performance analyzing tools for time profiling and data flow inspection in GStreamer apps."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/kirushyk/gst-instruments"
license=('GPL3')
depends=('gstreamer' 'gtk3' 'vala' 'xdot')
+makedepends=(meson)
source=('git+https://github.com/kirushyk/gst-instruments.git')
sha512sums=('SKIP')
build() {
cd gst-instruments
- ./autogen.sh --prefix=/usr
- make
+ meson --prefix /usr --buildtype=plain builddir
+ meson compile -C builddir
+ meson test -C builddir
}
package() {
cd gst-instruments
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" meson install -C builddir
}