summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfabrixxm2018-03-03 11:56:42 +0100
committerfabrixxm2018-03-03 11:56:42 +0100
commitf2e58ddb4cc37f654339d07a397caec04be21b65 (patch)
tree4df8fb31105ac02b83eab67ad011396010aeccef /PKGBUILD
downloadaur-f2e58ddb4cc37f654339d07a397caec04be21b65.tar.gz
Version 0.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee59dc5f3a10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fabio Comuni <fabrix.xm@gmail.com>
+
+pkgname=gst-plugin-qrcode
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="QRCode decoder plugin for GStreamer"
+arch=('i686' 'x86_64')
+license=('LGPL3')
+url="https://github.com/fabrixxm/gst-plugin-qrcode"
+depends=('gstreamer' 'quirc')
+source=("https://github.com/fabrixxm/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('b4759fc6fbe1e9650279b691a3120254')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+post_install() {
+ # is needed?
+ ldconfig
+}