summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:56:37 +0200
committerLubosz Sarnecki2015-06-22 22:56:37 +0200
commit2feb07ea10c2c10e3ee5e2607ed016f457fda4c0 (patch)
tree7f6a9a9f587246bbee93db420e415f9a14a770e8 /PKGBUILD
downloadaur-2feb07ea10c2c10e3ee5e2607ed016f457fda4c0.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4994a7eac88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Original Package: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+pkgname=gst-plugins-bad-git
+pkgver=1.3.1.1.16466.c842df1
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Bad Plugins"
+arch=('i686' 'x86_64')
+license=('LGPL')
+provides=('gst-plugins-bad='$pkgver)
+conflicts=('gst-plugins-bad' 'gst-plugins-gl')
+url="http://gstreamer.freedesktop.org/"
+depends=('mjpegtools' 'gst-plugins-base-git' 'curl' 'chromaprint' 'libmms' 'faad2' 'mpg123' 'faac' 'celt' 'libdca' 'soundtouch' 'spandsp' 'libdvdnav' 'libmodplug' 'libgme' 'opus' 'wayland')
+makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2')
+options=(!libtool !emptydirs)
+
+source='git+git://anongit.freedesktop.org/gstreamer/gst-plugins-bad'
+sha256sums=('SKIP')
+
+_gitname='gst-plugins-bad'
+
+pkgver() {
+ cd $_gitname
+ version=$(grep AC_INIT configure.ac | sed 's/AC_INIT(\[GStreamer Bad Plug-ins\],\[//' | sed 's/\],\[http:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=GStreamer\],\[gst-plugins-bad\])//')
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+
+ echo $version.$revision.$hash
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --enable-experimental --disable-fatal-warnings \
+ --with-gtk=3.0
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}