summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2020-12-27 10:57:33 +0100
committerNicola Murino2020-12-27 10:57:33 +0100
commit78fe5aea7a5be6f26094c44ee26e20473f805e12 (patch)
treee4188e73d7d839263fea7a71c13646c10a99f58d /PKGBUILD
parent9903a723efc0df380beee21735f2304fd13d3f62 (diff)
downloadaur-78fe5aea7a5be6f26094c44ee26e20473f805e12.tar.gz
update to 1.18.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b59e4b211e79..1f11621d422e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=gst-plugins-opencv
_pkgname=gst-plugins-bad
-pkgver=1.18.1
+pkgver=1.18.2
pkgrel=1
pkgdesc="GStreamer open-source multimedia framework OpenCV plugins"
url="https://gstreamer.freedesktop.org/"
@@ -9,22 +9,15 @@ arch=(x86_64)
license=(LGPL)
depends=(gst-plugins-base-libs opencv)
makedepends=(meson git)
-_commit=e5c3c106a2da607953fea36e3a253b382c939684 # tags/1.18.1^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
- "4.5.0.patch")
-sha256sums=('SKIP'
- '59c4401641d619f6ca0fffd853dad0a2e027d3aba1698c81d5017a23e6ac6ff4')
+_commit=b375ee4cdbcb98687c226d6564f8678a809cf02a # tags/1.18.2^0
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
-prepare() {
- cd $_pkgname
- patch -Np1 -i ../4.5.0.patch
-}
-
build() {
arch-meson $_pkgname build \
--auto-features=disabled \