summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2020-09-16 13:59:36 +0200
committerNicola Murino2020-09-16 13:59:36 +0200
commitf65f0646b85587d0ee1f4fd764458d1d395472de (patch)
tree63238b78e25cba5f2241310610c2f1385a0f983c /PKGBUILD
parent27e107a13cd73b3e33170c5a48a94dd24057e695 (diff)
downloadaur-f65f0646b85587d0ee1f4fd764458d1d395472de.tar.gz
Update to 1.18.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98366892eb25..34004ef82809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=gst-plugins-opencv
_pkgname=gst-plugins-bad
-pkgver=1.16.2
-pkgrel=6
+pkgver=1.18.9
+pkgrel=1
pkgdesc="GStreamer open-source multimedia framework OpenCV plugins"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
license=(LGPL)
depends=(gst-plugins-base-libs opencv)
makedepends=(meson git)
-_commit=a6f26408f74a60d02ce6b4f0daee392ce847055f # tags/1.16.2^0
-source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
- "4.4.0.patch")
-sha256sums=('SKIP'
- '5b103ae1c0a712950960fc1f01ed194d8b79bce6ec14ac899db85311456bfe4c')
+_commit=7cb583bb0427819a6b59b783e7df67961df2155f # tags/1.18.0^0
+source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
-prepare() {
- cd $_pkgname
- patch -Np1 -i ../4.4.0.patch
-}
-
build() {
arch-meson $_pkgname build \
--auto-features=disabled \