summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-01-12 00:55:37 +0100
committerFabioLolix2023-01-12 00:55:37 +0100
commitb64329f1f514bb0bea081f77a12719e1aa1f7b6a (patch)
treed1f73da23cc409e0d52d49dc9fd31fc0e12722fb /PKGBUILD
parent77d59142a4fb9473968668c20afd78551df8b0c3 (diff)
downloadaur-b64329f1f514bb0bea081f77a12719e1aa1f7b6a.tar.gz
v0.9.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b31c0a9015d4..ad5fb0d3a43e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,30 @@
# Contributor: Nikola Hadžić <nikola@firemail.cc>
pkgname=gst-plugins-rs
-pkgver=0.8.4
+pkgver=0.9.4
pkgrel=1
pkgdesc="GStreamer plugins written in Rust"
arch=(x86_64)
url="https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs"
license=(Apache LGPL2.1 MIT MPL2)
depends=(gstreamer gtk4 dav1d libsodium libwebp)
-makedepends=(git rust meson cargo-c clang)
+makedepends=(git rust meson cargo-c clang hotdoc)
+options=(!lto)
source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs.git#tag=${pkgver}")
sha256sums=(SKIP)
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ cargo fetch --target x86_64-unknown-linux-gnu --manifest-path "${srcdir}/${pkgname}/Cargo.toml"
+}
+
build() {
cd "${srcdir}/${pkgname}"
- arch-meson build -D csound=disabled -D sodium=system
+ arch-meson build \
+ -D csound=disabled \
+ -D dav1d=enabled \
+ -D sodium=system
+
ninja -C build
}