summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2019-09-28 15:46:10 +0300
committerAnton Leontiev2019-09-28 15:46:10 +0300
commitdb81f575fd2daec262fc5fde7834a7a3fba93c14 (patch)
treedff68c2381aab7d97e25dc7f4809e8c79abdedc1 /PKGBUILD
parentbcb345b564970094367cbc41f2830aeb869a5b79 (diff)
downloadaur-db81f575fd2daec262fc5fde7834a7a3fba93c14.tar.gz
Use meson to build package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f099f779d75..401673a0bd94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Anton Leontiev <scileont at gmail dot com>
+# Maintainer: Anton Leontiev <scileont /at/ gmail dot com>
# Co-Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=gst-rtsp-server
pkgver=1.16.1
-pkgrel=1
+pkgrel=2
pkgdesc="RTSP server library based on GStreamer"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
license=('LGPL')
+makedepends=('meson')
depends=("gst-plugins-base>=$pkgver")
source=("https://gstreamer.freedesktop.org/src/$pkgname/$pkgname-$pkgver.tar.xz"{,.asc})
sha256sums=('b0abacad2f86f60d63781d2b24443c5668733e8b08664bbef94124906d700144'
@@ -14,16 +15,18 @@ sha256sums=('b0abacad2f86f60d63781d2b24443c5668733e8b08664bbef94124906d700144'
validpgpkeys=('D637032E45B8C6585B9456565D2EEE6F6F349D7C') # Tim-Philipp Müller <tim@centricular.com>
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr
- make
+ meson --prefix /usr --buildtype plain $pkgname-$pkgver build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir/" install
- install -Dm755 examples/.libs/test-mp4 $pkgdir/usr/bin/gst-rtsp-mp4
- install -Dm755 examples/.libs/test-launch $pkgdir/usr/bin/gst-rtsp-launch
- install -Dm755 examples/.libs/test-netclock $pkgdir/usr/bin/gst-rtsp-netclock
- install -Dm755 examples/.libs/test-netclock-client $pkgdir/usr/bin/gst-rtsp-netclock-client
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm755 build/examples/test-mp4 "$pkgdir/usr/bin/gst-rtsp-mp4"
+ install -Dm755 build/examples/test-launch "$pkgdir/usr/bin/gst-rtsp-launch"
+ install -Dm755 build/examples/test-netclock "$pkgdir/usr/bin/gst-rtsp-netclock"
+ install -Dm755 build/examples/test-netclock-client "$pkgdir/usr/bin/gst-rtsp-netclock-client"
}