summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThibault Saunier2016-01-08 13:18:18 +0100
committerThibault Saunier2016-01-08 13:20:26 +0100
commitcfb612941ac6a964110c066fd0cabc39c81d90e5 (patch)
tree38cab6efb651ec3ca0a15a0cb3093f374369a0e5 /PKGBUILD
downloadaur-cfb612941ac6a964110c066fd0cabc39c81d90e5.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96f57567ba65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 256078 2015-12-14 20:36:26Z heftig $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gst-validate
+pkgver=1.6.0
+pkgrel=0
+pkgdesc="GStreamer Validate testing Framework"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://gstreamer.freedesktop.org/"
+depends=('gstreamer' 'gst-plugins-base')
+makedepends=('intltool' 'pkgconfig' 'gtk-doc' 'gobject-introspection' 'python2')
+source=(${url}/src/gst-validate/gst-validate-${pkgver}.tar.xz)
+sha256sums=('3baef8c7b5363293c20314a30afd54629849fc597669991fdcf92303602dafee')
+
+build() {
+ cd "${srcdir}/gst-validate-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
+ --with-package-name="GStreamer Validate (Arch Linux)" \
+ --with-package-origin="http://www.archlinux.org/" \
+ --enable-gtk-doc
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+check() {
+ cd "${srcdir}/gst-validate-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/gst-validate-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}