summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAliaksandr Stelmachonak a.k.a. ava1ar2017-09-26 03:17:02 -0400
committerAliaksandr Stelmachonak a.k.a. ava1ar2017-09-26 03:17:02 -0400
commit136af77b9125689ddae217130eb95bcaab8871f7 (patch)
tree85812ec2af11a9d9fa7bb4d8feff85e4be42cbbc /PKGBUILD
parent50fdefdf323146a0ed31cd44d32fef69a98d6860 (diff)
downloadaur-136af77b9125689ddae217130eb95bcaab8871f7.tar.gz
Adopted, changed source to the tarball, fix package build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a13382ddac14..5e2eaa07314f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,43 @@
-# Maintainer Yurii Kolesnykov <yurikoles@gmail.com>
-# Credit: Jan de Groot <jgc@archlinux.org>
+# Contributor: Yurii Kolesnykov <yurikoles@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
pkgname=gstreamer0.10
_pkgname=gstreamer
pkgver=0.10.36
-pkgrel=16
+pkgrel=17
pkgdesc="GStreamer Multimedia Framework"
arch=('i686' 'x86_64' 'armv7h')
license=('LGPL')
-url='https://github.com/triceratops1/gstreamer0'
+url='https://gstreamer.freedesktop.org'
depends=('libxml2' 'glib2')
-makedepends=('intltool' 'pkgconfig' 'gobject-introspection' 'git')
-source=("git+https://gitlab.com/gstreamer-sdk/$_pkgname.git#commit=3ddc31eaa18c3be1613e43430eca78a3e445639e"
+makedepends=('intltool' 'pkgconfig' 'gobject-introspection')
+source=("https://gstreamer.freedesktop.org/src/gstreamer/${_pkgname}-${pkgver}.tar.xz"
'tests-remove-silly-test_fail_abstract_new-check.patch'
'bison3.patch')
-sha256sums=('SKIP'
+sha256sums=('9151aa108c177054387885763fa0e433e76780f7c5655c70a5390f2a6c6871da'
'd3d3f4f04453831fdb4244bfe174a38c4e6f9f4da5c8c9050dcfa1a6097aad52'
'ed154e280abf59b24d98a8ab0fe868b449b26aa61f7ae3813fab8ac615fcaefa')
prepare() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
patch -Np1 -i ../tests-remove-silly-test_fail_abstract_new-check.patch
patch -Np1 -i ../bison3.patch
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
}
+
build() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
- --with-package-name="GStreamer (Archlinux)" \
- --with-package-origin="http://www.archlinux.org/" \
- --disable-gtk-doc --disable-static
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib --disable-gtk-doc --disable-static
make
}
package() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- #Remove unversioned gst-* binaries to get rid of conflicts
+ # Remove unversioned gst-* binaries to avoid possible conflicts
cd "${pkgdir}/usr/bin"
for bins in `ls *-0.10`; do
rm -f ${bins/-0.10/}