summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Bryan2017-09-04 09:02:19 -0500
committerJesse Bryan2017-09-04 09:02:19 -0500
commitf7e36bec15bcb67d9fd29ad4a602820d4b2d81e1 (patch)
tree7fb60e930a29d0c33f6d260c16a80c1f7f5eb1ec /PKGBUILD
downloadaur-f7e36bec15bcb67d9fd29ad4a602820d4b2d81e1.tar.gz
general: initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdf067c293d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jesse Bryan <jesse@winneon.moe>
+pkgname=gsu-git
+_pkgname=gsu
+pkgver=1.0.0.r5.gc5caaa5
+pkgrel=1
+pkgdesc="A general screenshot and upload utility for images, video, and gifs."
+arch=("any")
+url="https://github.com/winneon/${_pkgname}"
+license=("MIT")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=("maim" "ffmpeg" "curl" "jq" "bash")
+optdepends=(
+ "xclip: Copy URLs to clipboard after upload"
+)
+makedepends=("git")
+source=("${pkgname}::git+https://github.com/winneon/gsu.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+package() {
+ cd "${pkgname}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" install
+}