summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-11-15 11:06:38 -0700
committerMark Wagie2020-11-15 11:06:38 -0700
commit9b7da02ff4ba81c254bc81a52604d8b94952c7ae (patch)
tree021dc43376152cefabb6c6d68466e64d46165ea3 /PKGBUILD
downloadaur-9b7da02ff4ba81c254bc81a52604d8b94952c7ae.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f771898e6e64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gsubs
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A desktop app that finds you the perfect subtitle match"
+arch=('x86_64')
+url="https://cholaware.com/gsubs"
+license=('MIT')
+depends=('electron9')
+makedepends=('npm')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sanjevirau/gsubs/archive/v$pkgver.tar.gz"
+ "$pkgname.desktop"
+ "$pkgname.sh")
+sha256sums=('c75c59f273fa8fe8bc98182f50486552defb91dff247571509e436809b76a245'
+ '977b34d613aeac66d6009033e03c6d5138135be079bb5c6ab1442c91251683bf'
+ '01eb6b7b04403e5d8df76ba0ad4601e22054d25f922d7cab3b7f8a9d9877804c')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Disable building of dist packages
+ sed -i 's/AppImage/dir/g' electron-builder.yml
+ sed -i '16,17d' electron-builder.yml
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ npm install --cache "$srcdir/npm-cache"
+ npm run dist:linux
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -d "$pkgdir/usr/lib/$pkgname"
+ cp -r dist/linux-unpacked/resources "$pkgdir/usr/lib/$pkgname"
+
+ install -Dm644 build/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}