summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-12-20 21:48:16 +0200
committerAdrian Perez de Castro2021-12-20 21:48:26 +0200
commit1e8c8180948d2d8889cf8009360cd9087d9a4587 (patch)
tree4e9213fb8c2a352298b9978a185d6fb2a0d86eb4 /PKGBUILD
parent8785883940925435c03e1138227875cbfa35cedc (diff)
downloadaur-1e8c8180948d2d8889cf8009360cd9087d9a4587.tar.gz
Fix build with newer Meson versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c98d70b78d49..36c2862dc0e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=gtg
pkgver=0.5
-pkgrel=2
+pkgrel=3
pkgdesc='Personal GTD like organizer for the GNOME desktop environment'
url=https://wiki.gnome.org/Apps/GTG
arch=(any)
@@ -14,8 +14,15 @@ optdepends=('pdftk: for the export and print plugin'
'python-cheetah3: for the export and print plugin'
'texlive-bin: for pdflatex, needed by the export and print plugin'
'texlive-core: for pdfjam, needed by the export and print plugin')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/getting-things-gnome/gtg/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('631f5343301d7d72211398152fa081c0fa15154babc7ec900f13a39a2677d0edaf4fea534a83284207e8019926c9108dc1d8f25bdbeae85ef0665dfe1c7b768a')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/getting-things-gnome/gtg/archive/refs/tags/v${pkgver}.tar.gz"
+ fix-meson.patch)
+b2sums=('e724cbd015a6f0b6fee62c52283b56244490efb7df4e57b2e30745f58fbc41442b008f5c81b53cfd001f04a92ff53a14e2117d6c12d0d5a35fe49158b5f736fa'
+ '2864f0250d972fe08c349585222c0997ae68dfa6606c4043ffab6341870371180e654b6da6d532f31bbdb5c24a2c2b4ce42f6ef6988f30531f1cf32a0de35964')
+
+prepare ()
+{
+ patch -p0 < "${srcdir}/fix-meson.patch"
+}
build ()
{