summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-03-03 01:54:30 +0200
committerAdrian Perez de Castro2022-03-03 01:54:30 +0200
commite5e0c4197834155eb1b50ae08e6d2f36a88f46d3 (patch)
treebae92d7caf53e83df42d5ebe1526148f2fed1789 /PKGBUILD
parentdd0aa2ae762d0861afb39dd695c6a43d3af2d40b (diff)
downloadaur-e5e0c4197834155eb1b50ae08e6d2f36a88f46d3.tar.gz
Bump to version 0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20fff161d337..6b3f8ebe7077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=gtg
-pkgver=0.5
-pkgrel=4
+pkgver=0.6
+pkgrel=1
pkgdesc='Personal GTD like organizer for the GNOME desktop environment'
url=https://wiki.gnome.org/Apps/GTG
arch=(any)
license=(GPL)
-depends=(hicolor-icon-theme python-cairo python-dbus python-gobject
- 'python-liblarch>=3.1' python-lxml)
+depends=(hicolor-icon-theme python-cairo python-caldav python-dbus
+ python-gobject 'python-liblarch>=3.1' python-lxml)
checkdepends=(python-mock python-nose)
makedepends=(meson ninja)
optdepends=('pdftk: for the export and print plugin'
'python-cheetah3: for the export and print plugin'
'texlive-bin: for pdflatex, needed by the export and print plugin'
'texlive-core: for pdfjam, needed by the export and print plugin')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/getting-things-gnome/gtg/archive/refs/tags/v${pkgver}.tar.gz"
- fix-meson.patch)
-b2sums=('e724cbd015a6f0b6fee62c52283b56244490efb7df4e57b2e30745f58fbc41442b008f5c81b53cfd001f04a92ff53a14e2117d6c12d0d5a35fe49158b5f736fa'
- '888e266a62160a2e5812305d3912209615b3cfea9ea6f8f0889972419bb7648a91b7c8b9093debfe1453df1bc5f2553e4ca0a08af95e6bb3728bfad81f132872')
-
-prepare ()
-{
- patch -p0 < "${srcdir}/fix-meson.patch"
-}
+source=("https://github.com/getting-things-gnome/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.0.tar.xz")
+b2sums=('29c581e4264b3060561123e1b5e204d1fda2cb86fe34c2a285b415554a50ee0299ef500ad7895cbc7e6c00c5f25d2b1e79daad5c8b1233cf3b49f7b2289a8016')
build ()
{
rm -rf build
- arch-meson -Dprofile=default build "${pkgname}-${pkgver}"
+ arch-meson -Dprofile=default build "${pkgname}-${pkgver}.0"
ninja -C build
}
check ()
{
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}.0"
./run-tests
}