summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-01-10 09:26:04 -0700
committerMark Wagie2022-01-10 09:26:04 -0700
commitc20634519a1cf7714acc0256f36ebc2fae391721 (patch)
tree693106a20752bba25ba75a151a17057ade649998 /PKGBUILD
parent11caae5bd7b9250da0a4cfc6cd366a4f5d08eee7 (diff)
downloadaur-c20634519a1cf7714acc0256f36ebc2fae391721.tar.gz
adjust dependencies for upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe48000142b3..ab563279c870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Pablo Olmos de Aguilera Corradini <pablo <at] glatelier (dot} org>
# Contributor: Sander van Kasteel <info at sandervankasteel dot nl>
pkgname=gtg-git
-pkgver=0.5.r127.ga523934a
-pkgrel=1
+pkgver=0.5.r143.g7ce950c6
+pkgrel=2
pkgdesc="Getting Things GNOME! is a personal tasks and TODO-list items organizer for GNOME"
url="https://wiki.gnome.org/Apps/GTG"
arch=('x86_64')
license=('GPL')
-depends=('gtksourceview4' 'python-liblarch-git' 'python-lxml' 'libgnome-keyring')
+depends=('gtk3' 'gtksourceview4' 'libsecret' 'python-caldav' 'python-liblarch-git' 'python-lxml')
makedepends=('git' 'meson')
optdepends=('python-cheetah3: for the Export and print plugin'
'texlive-bin: pdflatex, for the Export and print plugin'
@@ -17,7 +17,7 @@ optdepends=('python-cheetah3: for the Export and print plugin'
'pdftk: for the Export and print plugin'
'hamster-time-tracker: send a task to the Hamster time tracking applet'
'yelp: view user manual')
-#checkdepends=('python-nose' 'python-mock')
+checkdepends=('python-nose' 'python-mock')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/getting-things-gnome/gtg.git')
@@ -33,10 +33,10 @@ build() {
meson compile -C build
}
-#check() {
-# cd "$srcdir/${pkgname%-git}"
-# python run-tests
-#}
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ python run-tests
+}
package() {
meson install -C build --destdir "$pkgdir"