summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-12-03 08:59:09 -0700
committerMark Wagie2023-12-03 08:59:09 -0700
commitee7c47ce5d54967d9ea9c0bc4d6aaba9e275a54f (patch)
treee405850b0e01c0e9e787bcc2ae9336833698a9ff /PKGBUILD
parent784638d226ae95185dd1f6574cdfce30a5f64aa2 (diff)
downloadaur-ee7c47ce5d54967d9ea9c0bc4d6aaba9e275a54f.tar.gz
add setproctitle opt depend
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 26 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a44a4bfe243b..8cbe6302a265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,38 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Baptiste Grenier <baptiste@bapt.name>
# Contributor: Pablo Olmos de Aguilera Corradini <pablo <at] glatelier (dot} org>
# Contributor: Sander van Kasteel <info at sandervankasteel dot nl>
pkgname=gtg-git
-pkgver=0.6.r78.g91993cda
-pkgrel=2
+pkgver=0.6.r79.g77fe2265
+pkgrel=1
pkgdesc="Getting Things GNOME! is a personal tasks and TODO-list items organizer for GNOME"
arch=('x86_64')
url="https://wiki.gnome.org/Apps/GTG"
license=('GPL')
-depends=('gtk3' 'gtksourceview4' 'libsecret' 'python-gobject'
- 'python-liblarch-git' 'python-lxml')
+depends=(
+ 'gtk3'
+ 'gtksourceview4'
+ 'libsecret'
+ 'python-gobject'
+ 'python-liblarch-git'
+ 'python-lxml'
+)
makedepends=('git' 'itstool' 'meson')
-checkdepends=('python-caldav' 'python-mock' 'python-pytest') ## TODO: Drop python-mock: https://archlinux.org/todo/drop-python-mock-checkdepends/
-optdepends=('python-caldav: CalDAV syncronization'
- 'python-cheetah3: for the Export and print plugin'
- 'texlive-bin: pdflatex, for the Export and print plugin'
- 'texlive-binextra: pdfjam, for the Export and print plugin'
- 'pdftk: for the Export and print plugin'
- 'hamster-time-tracker: send a task to the Hamster time tracking applet'
- 'yelp: view user manual')
+checkdepends=(
+ 'python-caldav'
+ 'python-mock' ## TODO: Drop python-mock: https://archlinux.org/todo/drop-python-mock-checkdepends/
+ 'python-pytest'
+)
+optdepends=(
+ 'hamster-time-tracker: send a task to the Hamster time tracking applet'
+ 'pdftk: for the Export and print plugin'
+ 'python-caldav: CalDAV syncronization'
+ 'python-cheetah3: for the Export and print plugin'
+ 'python-setproctitle: to set the process title when listing processes like ps)'
+ 'texlive-bin: pdflatex, for the Export and print plugin'
+ 'texlive-binextra: pdfjam, for the Export and print plugin'
+ 'yelp: view user manual'
+)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/getting-things-gnome/gtg.git')