summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy_Vetrov2019-03-23 23:52:49 +0300
committerAndy_Vetrov2019-03-23 23:52:49 +0300
commit73bab5b686c07b41258a71b3784d1ee7d2145a1d (patch)
treef94ec8cf8fbfb3bdfc3a259ddc653e77cef34715 /PKGBUILD
downloadaur-73bab5b686c07b41258a71b3784d1ee7d2145a1d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc1a3d4cd57e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andrey Vetrov <vetrov at mail dot ru>
+
+pkgname=gthumb-lite
+pkgver=3.7.1
+pkgrel=1
+pkgdesc="Image browser and viewer for the GNOME Desktop. Webkit-free version."
+url="https://wiki.gnome.org/Apps/Gthumb"
+arch=(x86_64)
+license=(GPL)
+provides=('gthumb')
+conflicts=('gthumb')
+replaces=('gthumb')
+depends=('dconf' 'librsvg' 'clutter-gtk' 'gst-plugins-base-libs' 'gsettings-desktop-schemas' 'libwebp'
+ 'json-glib' 'gtk3-print-backends')
+makedepends=('libchamplain' 'exiv2' 'libraw' 'docbook-xsl' 'yelp-tools' 'meson' 'git')
+optdepends=('libraw: read RAW files'
+ 'exiv2: metadata support'
+ 'libchamplain: map viewer')
+_commit=c2a0c415679b511d5f5436d89edff3445250d63a # tags/3.7.1^0
+source=("git+https://gitlab.gnome.org/GNOME/gthumb.git#commit=$_commit")
+sha256sums=('SKIP')
+
+build() {
+ mkdir build
+ meson --prefix /usr \
+ --buildtype=plain \
+ -Dlibchamplain=true \
+ -Dlibsecret=false \
+ -Dwebservices=false \
+ -Dlibbrasero=false \
+ "${srcdir}/${pkgname%-*}" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}