summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlban Fichet2020-05-05 01:25:26 +0200
committerAlban Fichet2020-05-05 01:25:26 +0200
commit21e5730076cc98c81767ede43a4fa4f6eef9c720 (patch)
treeb22da2cbbdb46773c1e2020adedd09525b282154 /PKGBUILD
parentb7a0365ae0cf18e595e1845e975a0e8affadf205 (diff)
downloadaur-21e5730076cc98c81767ede43a4fa4f6eef9c720.tar.gz
Updating to the new buildsystem
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a5a1081e11e..61f923a3ea93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alban Fichet <alban.fichet@inria.fr>
pkgname=gthumb-openexr-extension
-pkgver=1.2
-pkgrel=3
+pkgver=2.0
+pkgrel=4
pkgdesc="Extension for gThumb to support OpenEXR"
arch=('any')
url="https://github.com/yama-chan/gthumb-openexr-extension"
license=('GPL')
-depends=('gthumb>=3.4' 'glib2' 'gnome-common' 'gtk3' 'gconf' 'openexr')
-makedepends=()
+depends=('gthumb>=3.4' 'glib2' 'gtk3' 'gconf' 'openexr')
+makedepends=('git' 'meson')
checkdepends=()
provides=($pkgname=$pkgver)
source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git")
@@ -19,11 +19,13 @@ prepare() {
build() {
cd "$pkgname"
- ./autogen.sh --prefix=/usr
- make
+ meson --prefix=/usr build
+ cd build
+ ninja
}
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ cd build
+ ninja install
}