summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlban Fichet2021-04-19 18:06:05 +0200
committerAlban Fichet2021-04-19 18:06:05 +0200
commit60c6804e4881d9a81edadc1c24dd59792e2a1366 (patch)
tree63ea63dcca494bbd7f972de23c999ab2c3a25138 /PKGBUILD
parentd162eb90a8bca4a7f683ef58e59e9391fc42369e (diff)
downloadaur-60c6804e4881d9a81edadc1c24dd59792e2a1366.tar.gz
Updating the building script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b1cf511fc15..ff29192792c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Alban Fichet <alban.fichet@inria.fr>
pkgname=gthumb-openexr-extension
-pkgver=2.0
-pkgrel=7
+pkgver=3.10
+pkgrel=8
pkgdesc="Extension for gThumb to support OpenEXR"
arch=('any')
url="https://github.com/yama-chan/gthumb-openexr-extension"
license=('GPL')
depends=('git' 'gthumb>=3.10' 'glib2' 'gtk3' 'gconf' 'openexr')
-makedepends=('git' 'gnome-common')
+makedepends=('git' 'gnome-common' 'cmake')
checkdepends=()
provides=($pkgname=$pkgver)
-source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git")
+source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git#branch=cmake")
md5sums=('SKIP')
prepare() {
@@ -19,7 +19,8 @@ prepare() {
build() {
cd "$pkgname"
- ./autogen.sh --prefix /usr CFLAGS="-I/usr/include/gthumb"
+ cmake . -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ #./autogen.sh --prefix /usr CFLAGS="-I/usr/include/gthumb"
make
}