summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlban Fichet2021-04-15 22:40:48 +0200
committerAlban Fichet2021-04-15 22:40:48 +0200
commitd162eb90a8bca4a7f683ef58e59e9391fc42369e (patch)
tree3d92b76f78ecc6238282e6e5b453c976a28f2976 /PKGBUILD
parent6a3bf7713e6bfc4241ec3512ff7518c32f1f8f4e (diff)
downloadaur-d162eb90a8bca4a7f683ef58e59e9391fc42369e.tar.gz
Trying to fix compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03fe47046810..8b1cf511fc15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alban Fichet <alban.fichet@inria.fr>
pkgname=gthumb-openexr-extension
pkgver=2.0
-pkgrel=6
+pkgrel=7
pkgdesc="Extension for gThumb to support OpenEXR"
arch=('any')
url="https://github.com/yama-chan/gthumb-openexr-extension"
license=('GPL')
-depends=('git' 'meson' 'gthumb>=3.10' 'glib2' 'gtk3' 'gconf' 'openexr')
-makedepends=('git' 'meson')
+depends=('git' 'gthumb>=3.10' 'glib2' 'gtk3' 'gconf' 'openexr')
+makedepends=('git' 'gnome-common')
checkdepends=()
provides=($pkgname=$pkgver)
source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git")
@@ -19,11 +19,11 @@ prepare() {
build() {
cd "$pkgname"
- meson --prefix /usr --buildtype=plain build
- ninja -v -C build
+ ./autogen.sh --prefix /usr CFLAGS="-I/usr/include/gthumb"
+ make
}
package() {
cd "$pkgname"
- ninja -C build install
+ make install
}