summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2017-06-20 15:49:26 +0200
committerLuca Weiss2017-06-20 15:49:26 +0200
commit7f2f2579e35b3a195eaf0f63d7c18c86d37906fb (patch)
tree8139e7f46310861c8e4d9b794292c515525bf7b8 /PKGBUILD
parent3991742ca100375a3dffcd3027c0749deeaa37ab (diff)
downloadaur-7f2f2579e35b3a195eaf0f63d7c18c86d37906fb.tar.gz
v1.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f8d27b8cd17..59e4575e2b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=gti
-pkgver=1.3.0
-_commit="530a7ff"
+pkgver=1.6.1
pkgrel=1
pkgdesc="A silly git launcher"
arch=('i686' 'x86_64')
url="http://r-wos.org/hacks/gti"
license=('custom')
-source=("https://github.com/rwos/gti/tarball/v$pkgver"
+source=("https://github.com/rwos/gti/archive/v$pkgver.tar.gz"
'LICENSE')
-md5sums=('0d8e4206fda5a343af7a1c530e7bfc73'
- '28c2baebd9f1dbe5498bae7ca90c005f')
+sha512sums=('a97693f43ea2b1c8b6312991ea2fd7c0eb4b9288da1992d187582f98429204c1bc81ce98a3029b30a7eecea78eb1ba6d2c3aa8497d1f104919cf7980d382c880'
+ '1ffb66b89716dfcc5d093bc63a8744e8377d4acd97d8df90c486810535c108b18f6ca1a3dd4eb3cd9027e6330392871c702ca49a72afce5a7676380788c7440f')
build() {
- cd "$srcdir/rwos-gti-${_commit}"
+ cd "$srcdir/gti-$pkgver"
make
}
package() {
- cd "$srcdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd "rwos-gti-${_commit}"
- install -Dm755 gti "$pkgdir/usr/bin/gti"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "gti-$pkgver/gti" "$pkgdir/usr/bin/gti"
}
# vim:set ts=2 sw=2 et: