summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2018-06-04 18:50:32 +0200
committerFrederik “Freso” S. Olesen2018-06-04 18:50:32 +0200
commitb7a589dbcf5f51e2095d076bd3b71a034badcb37 (patch)
tree51808915df7d611b7feee3cdb8fdeee2f340097f /PKGBUILD
parentd7a52093020e33a212b25ff3faa9a210a844d14f (diff)
downloadaur-b7a589dbcf5f51e2095d076bd3b71a034badcb37.tar.gz
Install .desktop and icon file(s) from upstream
gtimelog-large.png is 400x400, but installing into 512x512 as that is the smallest category that the icon fits into, per hicolor's index.theme. Changes heavily inspired by (very) similar patch by Mrmaxmeier.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 913f5596377b..e08735a549c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gtimelog
pkgver=0.11
-pkgrel=1
+pkgrel=2
pkgdesc='Small GTK+ app for keeping track of your time'
arch=('any')
url='https://gtimelog.org/'
@@ -15,4 +15,9 @@ sha256sums=('ab43075afdd732e35bfc9f39ee425c23efe0f68258f3bc5688791a12028e6fc7')
package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ # Install .desktop file and icon(s)
+ install -Dm0644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm0644 "src/${pkgname}/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/48x48/apps/${pkgname}.png"
+ install -Dm0644 "src/${pkgname}/${pkgname}-large.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
}