summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Schulte2020-04-13 16:43:54 -0400
committerEric Schulte2020-04-13 17:03:32 -0400
commit10b8cd252d067f680e961b43854b488cc5440c3b (patch)
tree23e1a4307666e8d8130d97f7dec0dab5505448b8 /PKGBUILD
parent08fb6b2afc58b5556a29f54574d2eb31a3358395 (diff)
downloadaur-10b8cd252d067f680e961b43854b488cc5440c3b.tar.gz
Build and install the python API
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0965e6a8ead1..e0ebe992ba28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Schulte <eschulte@grammatech.com>
_srcname=gtirb
pkgname=gtirb-git
-pkgver=v1.2.0.r91.g2aa2dcec
+pkgver=v1.1.0.r165.g8449f1d6
pkgrel=1
pkgdesc="GrammaTech Intermediate Representation for Binaries"
arch=('x86_64')
@@ -24,13 +24,13 @@ pkgver() {
build() {
cd "$_srcname/"
- cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++ -DGTIRB_PY_API=OFF -DGTIRB_CL_API=OFF
+ cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=clang++ -DGTIRB_CL_API=OFF
cmake --build build --target all doc
}
package() {
cd "$_srcname/"
- make -Cbuild DESTDIR="$pkgdir" install
+ make -Cbuild DESTDIR="$pkgdir" install install-python
mkdir -p "$pkgdir"/usr/share/doc/$_srcname
cp -R build/doc/html/ "$pkgdir"/usr/share/doc/$_srcname
}